Wallet stuck on synchronization?

Hello!

I’ve been mining for some time now and after a power outage I restarted my node but it seems like the wallet is “stuck” on active synchronization…

I have received 2 coins from mining which isn’t showing in my wallet.

Any advice on how to fix this or advice on how to sync the wallet?

Thanks!

1 Like

I have the same problem. 8 days with Active synchronization

1 Like

8 days ?! :astonished:

Wow I really hope that we can get support on this issue, I have decided to rather mine to a new wallet but I still have some ergo that’s missing…

1 Like

Same here! Over 3 days with Active synchronization. Only node was synchonize but not wallet. When we can get support on this issue?!

1 Like

I set up the node and it was synchronized. I got a wallet address with swagger. But I think I forgot to sync the wallet. Then I fiddled with settings on gpus etc. When I starten mining I started the node and the miner but i did not start the API. I mined for a few weeks when I thought I should check the wallet. When I started The API The wallet balance was zero and both node and wallet says active synchronization and have done so the last week. When I click on the wallet address link it shows the right amount I have been mining.

Is my mistake that I have not run the API while mining?

Will the node and wallet synchronize after a few weeks or have I done something wrong?

1 Like


Hi! I have already reinstalled the wallet 3 times, the node is syncing, the wallet is not syncing.

1 Like

So I have sent a mail to the official ergo platform… no reply…

I then tried the Ergo Platform on telegram but that community seems to be nothing short of cancer.

I then joined an Ergo mining group on telegram and the consensus there was to cut my losses and mine directly to a Yoroi wallet instead.

1 Like

Discord is the right place to ask such questions.

1 Like

In this case node is not synced also, height is not corresponding to the current best height in the network.

To understand what’s going on, please provide following data:

  • how do you run the node (jar/docker, OS)
  • config
  • is anything wrong in the logs? “cat ergo.log | grep ERR”
1 Like

The problem is solved!

  1. Install the wallet, run it with the ergo.conf configuration file, and wait for the node to sync.
    java -jar ergo-.jar --mainnet -c ergo.conf

ergo {
directory = “c:/ergo”
node {
mining = false
}
wallet.secretStorage.secretDir = “c:/ergo”
}

  1. Copy the api key to swagger, close PowerShell, and edit ergo.conf

ergo {
directory = “c:/ergo”
node {
mining = false
}
wallet.secretStorage.secretDir = “c:/ergo”
}

scorex {
restApi {
# Hex-encoded Blake2b256 hash of an API key.
# Should be 64-chars long Base16 string.
# below is the hash of the string ‘hello’
# replace with your actual hash
apiKeyHash = “324dcf027dd4a30a932c441f365a25e86b173defa4b8e58948253471b81b72cf”
}
}

  1. Launch the wallet, create a wallet, and wait for the synchronization to complete.

p. s.
Create a wallet only after syncing with the node.
With this configuration, the wallet does not work:

ergo {
directory = “c:/ergo”
node {
mining = false
}
wallet.secretStorage.secretDir = “d:/ergo”
}

2 Likes

Does this method restore wallet with missing coins?

I realized that my node was not ever synced. Node syncing was stuck at “best block” and never went to “height count”. Huge ergo.txt file 27Gb in ergo folder. Started a new sync yesterday evening and hoping it is synced when I am home from work today. Then I can test freemans options.

Yes, I believe so.

  1. Install the wallet and sync the node.
  2. Close the wallet (Stop PowerShell) and enter the api key in the configuration file.
  3. Launch the wallet and wait for the wallet to sync.

Good luck

2 Likes

Solved it :grinning:.

  1. Started a new session yesterday (created a new folder not to trash anything in the old one) and restored wallet. New address, zero balance.
  2. When the node was synced (about 24h) I stopped it. Edited conf-file, removed APIkey section. Copied old wallet folder (with the ERG in its address) to the new node folder. This is probably unnecessary.
  3. Restarted node and waited it to sync again (a few minuters).
  4. Opened swagger ui and made a APIkey with the same secret as in my first wallet.
  5. Stopped the node. Edited The conf file with the apikey.
  6. Started node. Set apikey. Waited for wallet to sync (about an hour). When synced, all of the ERG was there.
    Good luck

The reason for my slightly different approach to Freemans was that I already restored the wallet when I started the sync of the node and did not felt like to start over. That’s why I copied the old wallet folder to the new .ergo folder

3 Likes

@Freeman @peternord71

Thank you so much for all the help and advice, I will try your methods later today and report back.

Thanks again! :clap: :clap: :clap:

1 Like

It is hard to give any advice when not much info given. Please specify when reporting:

  • what are you running (jar or docker image)
  • how (launch command)
  • config

then usually it is clear how a problem could be solved

Apologies for the late response. @Freeman resolved this issue. Thanks

Hi, i had similar problem. I followed “absolete” insctruction, which are on main page. I was able to manage the settings somehow and I went through the swagger to set up the validation node and I skip waiting on sync node and went straigt to the wallet set up, because someone wanted mining so badly :smiley: . So at the beginning both wallet and node was syncing and worker mined and there was a finally first payout and nothing came to the wallet. Ofcourse I manytimes cancelled syncing during minig and i started to ask myself WTF. So i came here and started to prepare myself to do some repairs…, BUT! During the investigating I let the node and wallet syncing at the same time and now finally the end of syncing is sucssesfully done and with this came every payouts aswell. Sorry for my english and be patient! :smiley: