Ergo miner on linux takes forever to install

I’m trying to install ergo on linux for 2 days. I can’t finish the instalation and I can’t keep my terminal opened for two days because its a remote machine, I’m not installing this node locally but udner a SSH terminal.
I’m asking if there’s anyway to make it easier or to run in background.

This is the command I’m trying
curl -s https://raw.githubusercontent.com/ergoplatform/ergo/master/ergo-installer.sh | sh -s – --mode=mining --app-dir=/home/cardano/ergo --api-key=APYKEY

Ergo node with config file will be installed into ‘/home/cardano/ergo’ directory and will be named as HOSTNAME and has API key ‘…’.

Ergo directory ‘/home/cardano/ergo’ already exists.

Latest known Ergo release: v4.0.23, downloading it to /home/cardano/ergo/ergo.jar with overwrite…

Ergo was downloaded to /home/cardano/ergo/ergo.jar

Executing ergo node to obtain API key hash…

If the SSH session is closed or terminated by the user the install will stop to avoid this you could attach the Terminal Session with Screen. Include the screen command in your Linux command arguments. By using the screen command will allow you to perform a long-running task on a remote machine.

apt-get install screen

I can try that, thank you. is that normal take so long? what are minimum hardware requirements?

the node is suposidelly sync but I can open the swagger at http://myip:9053/swagger#/utils/hashBlake2b

I tried the installer but never could make it return it prints forever dots and the command java -Xmx4g -jar ergo-.jar --mainnet -c ergo.conf
Is what I’m trying now.
I’m following this tutorial

It does usually take some time to sync the full chain.

Download Ergo Java file from https://github.com/ergoplatform/ergo/releases/

Then create a folder called ergo inside that folder add the java installer file and also create a config file.

touch ergo.conf

ergo {
  node {
    mining = true
  }
}

then try and launch the command.

java -Xmx4g -jar ergo-4.0.23.jar --mainnet -c ergo.conf

Or in your case you could try using screen.

screen java -Xmx4g -jar ergo-4.0.23.jar --mainnet -c ergo.conf

1 Like

hello my node is sync now and running, I think the issue was the firewal so I disabled it completely. Now, I need to know what ports I need to open.
Thank. you very much this looks very good

1 Like

The API must not be accessible from the Internet. 9053 is the port used for the node interface and the swagger ultiliy. Node interface should not be accessible over the internet and only be accessible locally for security reasons.